因为人员变动,我也需要去解决Eclipse的相关问题。一个上古时代的工程在我电脑版本死活跑不起来。一起报Dx unsupported class file version 52.0 xxxxxx错误。
查看网上的解决方法,大部分都是因为原工程编译的android版本太低了,需要把1.8版本降低到1.7版本。

右键工程-->Properties-->Java Compiler -->选择你安装的jdk版本.

但是我试了,在我机子上无用,且同步Installed JREs里面匹配也是无用的。甚至换到1.6版本仍然无用。查询了相关的资料,发现都是老的,且基本都是这个方法,陷入绝望,想到4.4可以1.7jdk。但项目是android4.0.4版本。于是死马当活马医,在project.properties中更改 target=android-14 为 target=android-19 。成功运行。

参考资料Dx unsupported class file version 52.0

标签: none

添加新评论