前几天谷歌开发者大会又开始大力推荐他的Flutter了。唉,作为一个懒惰的码畜。错过了RxJava,错过了kotlin,看到Flutter本想学学的,也被新创建的Drat语言伤透了心。但是谷歌爸爸自研新系统的消息愈演愈烈,没办法,还是稍微接触下先,准备学习吧。
首先安装环境就发现一个蛋疼的问题,Flutter有个中文网站,里面的中文教程windows安装的第一篇是0.2.8的环境,最新貌似变成0.3.2了,果然测试版开发就是快。这不是重点,重点是,git下载的话,你会后悔的,如果不想变换国内节点配置,直接下载官方的压缩包就是了。然后还是常规的加入环境变量。
碰到问题如下:

  1. 0.2.8环境不知道和3.1.2的android studio产生了什么奇妙的化学反应,在我这台笔记本死活卡在创建flutter应用中。换成0.3.2就好了。
  2. flutter doctor --android-licenses 在cmd中是正常的,且同意过了,但是在android studio的初始工程中,死活报错,我开始怀疑是环境变量Android sdk配错了,但是不是,这个bug找了半天,才在stackoverflow看到。android的sdk.dir莫名是上一个工程的sdk目录。切换就好了。
    运行成功截图如下。

请输入图片描述
改成符合标题的

请输入图片描述
本文只是记录下,运行flutter的hello world的坑。2333.学习等慢慢啃吧

标签: none

添加新评论